Client Installation Troubleshooting

Error Reaching Domain Controller

Symptom

During Client installation, you see the following error:
Error reaching domain controller(s)...

Cause

In order to associate users to their respective devices, the AppGuru Client reads DNS logs from a domain controllers on the network.  For this reason, you must enter Domain Administrator credentials when prompted to enter Active Directory credentials by the client installation wizard.

Solution

You must enable the Remote Event Log Management exception in the Windows Firewall Settings on all domain controllers that should track devices in your AD environment.

Failure to Detect Traffic in a Hyper-V Virtual Environment


Symptom

The virtual NIC only detects cloud traffic from the local machine. It fails to detect traffic on the internal network going to cloud apps.

Cause

This can happen when the AppGuru Client is installed on a virtual server (Windows Server 2012 and Windows Server 2012 R2) that is running in Windows Hyper-V. In this case, extra steps are required to activate promiscuous mode.

Solution

Complete these tasks to activate promiscuous mode.
This solution only applies when installing the AppGuru Client to Windows Server 2012 and Windows Server 2012 R2.  

Task 1. Required only for Windows Server 2012 (not R2)
Download the hotfix from Microsoft 

Task 2. Run the following commands in Windows Powershell:

$a = Get-VMSystemSwitchExtensionPortFeature -FeatureId 776e0ba7-94a1-41c8-8f28-951f524251b5 

$a.SettingData.MonitorMode = 2

add-VMSwitchExtensionPortFeature -ExternalPort –SwitchName  "{Virtual NIC Name from Virtual Switch settings}"  -VMSwitchExtensionFeature $a

Task 3. Set mirroring to destination, as follows:

  1. Open the Hyper/V server manager console. 
  2. Go to virtual networks
  3. Under port mirroring, set mirroring to destination

Feedback and Knowledge Base